Excel 2010 Formulas and Functions

One of Excel's most useful features is that it allows users to create custom formulas to perform calculations on their data. Excel also contains built-in formulas called functions that make it easy to perform common calculations on data. Here you will find step by step tutorials, tips and shortcuts on how to use formulas and the common and less common functions available in Excel.
**Formula Basics**

Formulas in Microsoft Excel begin with an equal sign. The equal sign tells Excel that the succeeding characters constitute a formula. If you don't enter the equal sign, Excel will treat your entry as text and the calculation will fail. To show how formulas work, we'll begin with a simple exercise by selecting blank cell A1. Then type =5+5, and press Enter.

Excel performs the calculation and produces a result of 10 in cell A1. Notice the formula bar shows the formula you just typed. What appears in the cell is the result; what appears in the formula bar is the underlying value, which is a formula in this case.
Order of Operation

When performing calculations in a formula, Excel follows certain rules of precedence: Excel calculates expressions within parentheses first. Excel calculates multiplication and division before addition and subtraction. Excel calculates consecutive operators with the same level of precedence from left to right.
For example, the formula $= 10+10*2$ gives a result of 30 as Excel multiplies 10 by 2 and then adds 10. However, the formula $=(10+10)*2$ produces a result of 40. This is because Excel calculates the expression $(10+10)$ within the parentheses first. It then multiplies by 2.

If you are unsure of the order in which Excel calculates, use parentheses - even if the parentheses aren't necessary. Parentheses also make your formulas easier to read.
Basic Formulas
Add the Values in Rows or Columns
Use the SUM function, which is prewritten formula, to add all the values in a row or column:
1. Click your mouse in the cell in which you wish your result to appear
2. Click the AutoSum button on the Home Tab or the Formulas Tab
3. Highlight the range of cells you wish to add
4. Press Enter

To add some of the values in a column or row:
1. Type an equal sign, type SUM, then type an opening parenthesis.
2. Type or select the cell references you want to add. A comma (,) separates individual arguments that tell the function what to calculate.
3. Type a closing parenthesis, and then press ENTER. For example: =SUM(B2:B4, B6) and =SUM(B2, B5, B7)
Find the Average, Maximum, or Minimum
Use the AVERAGE, MAX, OR MIN functions.
1. Click your mouse in the cell in which you wish your result to appear
2. Click the arrow next to AutoSum on the Home Tab or the Formulas Tab.
3. Click the Average, Max, or Min
4. Highlight the range of cells you wish to find the value for
5. Press Enter
To see more functions, click More Functions on the AutoSum list to open the Insert Function dialog box
OR go to the Formulas Tab and click on the More Functions orange textbook icon

Tip: You can also enter formulas and cell references by typing them in the formula bar after selecting a cell
Ranges and Individual Cells

As you start to write excel formulas, you may realize you want to use a range of cells or nonadjacent cells in your formula. A range of cells will include the value of every cell within the range specified (for example, the range A1:A4 includes the cells A1, A2, A3 & A4). Ranges of cells are identified with a colon.

Nonadjacent cells can be listed in the formula by separating them with a comma rather than a colon.

For example, =SUM(A2,A4) will add cells A2 and A4, but not A3.
Copy a Formula
Using the Fill Handle
1. Select the cell that contains the formula, then position the mouse pointer over the lower-right corner of the cell until the black cross (+) appears.
2. Drag the fill handle over the cell or cells to which you want to copy the formula, then release the mouse button.

Using Traditional Copy & Paste
1. Select the cell that contains the formula, and on the Edit menu, click Copy.
2. Select the cell or cells that you want to copy it to.
   a. To copy the formula and any formatting, on the Edit menu, click Paste.
   b. To copy the formula only, on the Edit menu, click Paste Special, and then click Formulas.
Referencing Cells in Formulas
You can include or reference other cells in a formula. When you do, the result of the formula depends on the values in the referenced cells and changes automatically when the values in the referenced cells change. This is extremely powerful in what-if scenarios.
To see how this works, enter 10 in cell A1. Now select cell A2 and type =A1*2, and press ENTER. The value in cell A2 is 20. If you change the value in cell A1 from 10 to any value, the value in cell A2 will also change. Cell references are especially helpful when you create complex formulas, or conduct what-if analysis.
Quick Reference Guide
Add, Subtract, Multiply & Divide

Type an equal sign (=), use math operators, and then press ENTER.

=10+5 to add
=10-5 to subtract
=10*5 to multiply
=10/5 to divide

Formulas are visible in the formula bar when you select a cell that contains a result. If the formula bar is not visible, on the Tools menu, click Options. Click the View tab, and select the Formula bar check box.
Understand Error Values

#### : The column is not wide enough to display the content. Increase column width, shrink contents to fit the column, or apply a different number format.

#REF! : A cell reference is not valid. Cells may have been deleted or pasted over.

#NAME? : You may have misspelled a function name.
Commonly Used Functions & Formulas
Below is a list and description of commonly used formulas within Excel.

Math & Trig Icon

PRODUCT Function
The PRODUCT function provides a quick way to multiple numbers in a Excel. The advantage of using this function becomes apparent if you have several numbers to multiply together. It is easier then building a long formula.

The syntax for the PRODUCT function is:

\[ =\text{PRODUCT}( \text{Number}_1, \text{Number}_2, \ldots, \text{Number}_{255} ) \]

TIP: Up to 255 numbers can be entered into the function.
SUMIF Function

The SUMIF function is used to add up the values in cells in a selected range that meet certain criteria. The syntax for the SUMIF function is: \( = \text{SUMIF} \left( \text{Range}, \text{Criteria}, \text{Sum Range} \right) \)

* Range - the group of cells the function is to search.
* Criteria - determines whether the cell is to be counted or not.
* Sum Range - the data range that is summed if the first range meets the specified criteria. If this range is omitted, the first range is summed instead.
**SUMIFS Function**

The SUMIFS function adds up the data in selected cells when specific criteria are met in two or more ranges of data. The SUMIFS function works like the AND function in that it only sums the data if the criterion for each range is true.

The syntax for the SUMIFS function is:  

```
=SUMIFS (Sum_range, Criteria_range1, Criteria1, Criteria_range2, Criteria2, ...)
```

* Sum_range - the range of cells to be added.
* Criteria_range - the range of cells the function is to search.
ROUND Function

The ROUND function is used to reduce a given value to a specific number of decimal places.

The syntax for the ROUND function is:

= ROUND ( Number, Num_digits )

*Number - the value to be rounded.
*Num_digits - the number of decimal places to reduce the above number to
ROUNDOWN Function

The ROUNDDOWN function is used to round a number down towards the next lowest number. ROUNDDOWN is similar to the ROUND function except that it always rounds a number downward while the ROUND function will round up or down depending on whether the last digit is greater than or less than 5.

For example, the ROUND function would round the number 34.567 up to 34.6 because the second decimal place (6) is greater than 5. Since ROUNDDOWN doesn't care whether the second digit is greater or less than 5 it rounds the answer down to 34.5.

The syntax for the ROUNDDOWN function is:

```
= ROUNDDOWN ( Number, Num_digits )
```

Number - the value to be rounded.
Num_digits - the number of decimal places to reduce the above number to.
ROUNDUP Function

The ROUNDUP function is used to round a number upwards towards the next highest number. ROUNDUP is similar to the ROUND function except that it always rounds a number upward while the ROUND function will round up or down depending on whether the last digit is greater than or less than 5.

For example, the ROUND function would round the number 34.231 down to 34.2 because the second decimal place (3) is less than 5. Since ROUNDUP doesn't care whether the second digit is greater or less than 5 it rounds the answer up to 34.3.

The syntax for the ROUNDUP function is:

= ROUNDUP ( Number, Num_digits )

*Number - the value to be rounded.
*Num_digits - the number of decimal places to reduce the above number to.
The IF function, one of Excel’s logical functions, tests to see if a certain condition in a spreadsheet is true or false.

The syntax for the IF function is:

```
=IF ( logical_test, value_if_true, value_if_false )
```

* logical_test – a value or expression that is tested to see if it is true or false.
* value_if_true – the value that is displayed if logical_test is true.
The NETWORKDAYS function, one of Excel's Date and Time functions, can be used to count the number of working days between two dates - such as the start and end dates for a project. The function automatically removes weekend days from the total. Specific holidays can also be omitted.

The syntax for the NETWORKDAYS function is:

= NETWORKDAYS ( Start_date , End_date , Holidays )

*Start_date - the start date of the chosen time period.
*End_date - the end date of the chosen time period.
*Holidays - can be used to exclude one or more dates from the total number of working days (optional).
DATEDIF Function

The DATEDIF function can be used to calculate the number of days between two dates in versions of Excel from 97 to 2010. An interesting point about DATEDIF is that it is an "undocumented" function which means it is not listed with other functions under the Formulas tab in Excel 2010.

To use the function you must type it manually into a cell on the worksheet rather than using the dialog box method available for other functions.

The syntax for the DATEDIF function is:

= DATEDIF (start_date , end_date , unit )

The function has three arguments that need to be entered as part of the function:
* `start_date` - the first or starting date.
* `end_date` - the second or last date.
* `unit` - tells the function to find the number of days ("D"), complete months ("M"), or complete years ("Y") between the two dates.
The unit argument can also be a combination of days, months, and years:
* "YM" - excludes years - calculates the number of months between two dates as if the dates were in the same year.
* "YD" - excludes years - calculates the number of days between two dates as if the dates were in the same year.
* "MD" - excludes months - calculates the number of days between two dates as if the dates were in the same month and year.
DAYS 360 Function

The DAYS360 function, one of Excel's Date and Time functions, can be used in accounting systems to calculate the number of days between two dates based on a 360-day year (twelve 30-day months).

The syntax for the DAYS360 function is:

= DAYS360 ( Start_date , End_date , Method )

* Start_date - the start date of the chosen time period.
* End_date - the end date of the chosen time period.
* Method - A Boolean value (TRUE or FALSE).

*If TRUE -- the function uses the U.S. method of calculating start and end dates.
*If FALSE -- the function uses the European method of calculating start and end dates.
The WORKDAY function can be used to calculate the end date or start date of a project for a given number of business days. The number of business days cannot include weekend days. Specific holidays can also be omitted.

The syntax for the WORKDAY function is:

= WORKDAY ( Start_date, Days, Holidays )

*Start_date - the start date of the project or time period in question.
*Days - the number of days work on the project occurred after the Start_date.
*Holidays - can be used to exclude one or more dates from the total number of working days (optional)
AutoSum
AVERAGE Function

The AVERAGE function, one of Excel's statistical functions, is used to find the average or arithmetic mean of a given list of arguments. The syntax for the AVERAGE function is:

\[
= \text{AVERAGE}(\text{argument1, argument2, ... argument255})
\]

Argument1, argument 2, ... argument 255 can be numbers, named ranges, arrays, or cell references.

Tip: Up to 255 arguments can be entered.
The MAX function, one of Excel's statistical functions, is used to find the largest or maximum number in a given list of values or arguments.

The syntax for the MAX function is:

```
=MAX( argument1, argument2, ... argument30 )
```

Argument1 ... argument 30: The arguments can be numbers, named ranges, arrays, or cell references.

Up to 30 arguments can be entered.
MIN Function

The MIN function, one of Excel's statistical functions, is used to find the smallest or minimum value in a list of numbers or arguments.

The syntax for the MIN function is:
=MIN ( argument1, argument2, ... argument30 )

Argument1 ... argument 30: Arguments can be numbers, named ranges, arrays, or cell references. Up to 30 arguments can be entered.
AVERAGEIF Function

The AVERAGE IF function is used to find the average of values in cells in a selected range that meet certain criteria.

The syntax for the AVERAGE IF function is:

\[ =\text{AVERAGEIF}( \text{Range, Criteria, Sum Range}) \]

*Range - the group of cells the function is to search.
*Criteria - the number, expression, or text statement that the data in the Range above is to determines whether the cell is to be counted or not.
*Average_range - the data range that is averaged if the first range meets the specified criteria. If this range is omitted, the first range is averaged instead.
COUNTIF Function

The COUNTIF function, one of Excel's COUNT functions, is used to count up the number of cells in a selected range that meet specified criteria.

The syntax for the COUNTIF function is:

=COUNTIF ( Range, Criteria)

*Range - the group of cells the function is to search.
*Criteria - determines whether the cell is to be counted or not. This can be a number, expression, cell reference, or text string.
COUNT Function

Excel's COUNT function is one of a group of Count Functions that can be used when you need to total the number of cells in a selected range. The COUNT function's job is to only add up the cells in a selected range that contain numbers. It ignores empty cells or those contain text. If a number is later added to an empty cell the function will be automatically updated to include this new data.

Be aware that dates, times, functions, and formulas are stored as numbers in Excel. The COUNT function will, therefore, include any cells containing these types of data in the total.

The syntax for the COUNT function is:

`=COUNT( Range )`

Range - the group of cells the function is to count