The most important mathematical functions

Lecture -8-

By lec. (Eng.) Hind Basil

University of technology

Department of Materials Engineering
The most important mathematical functions
<table>
<thead>
<tr>
<th>Example</th>
<th>The general formula for the function</th>
<th>The function name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Find the total range</td>
<td>=SUM(A1:A6)</td>
<td>Sum</td>
</tr>
<tr>
<td>Find the sum of the values separate</td>
<td>=SUM(A1,D2,B5 )</td>
<td></td>
</tr>
<tr>
<td>Find the mean</td>
<td>=Average(A1:A6)</td>
<td>Average</td>
</tr>
<tr>
<td>To calculate the number of digits in a range</td>
<td>=Count(A1:A6)</td>
<td>Count</td>
</tr>
<tr>
<td>Maximum value within the range</td>
<td>=Max(A1:A6)</td>
<td>Maximum Value</td>
</tr>
<tr>
<td>The minimum value within the range</td>
<td>=Min(A1:A6)</td>
<td>Minimum Value</td>
</tr>
</tbody>
</table>
The most important mathematical functions

<table>
<thead>
<tr>
<th>Purpose</th>
<th>The general formula for the function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Function of power or exponent</td>
<td>=POWER(A1 ;2)</td>
</tr>
<tr>
<td>Returns the square root</td>
<td>=SQRT(A1)</td>
</tr>
<tr>
<td>Approximation to the nearest integer</td>
<td>=INT(A2)</td>
</tr>
</tbody>
</table>
The most important functions of the date and time

<table>
<thead>
<tr>
<th>Purpose</th>
<th>The general formula for the function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert the date</td>
<td>=Date()</td>
</tr>
<tr>
<td>Return today's date</td>
<td>=Today()</td>
</tr>
<tr>
<td>The return of today's date and the current time</td>
<td>=Now()</td>
</tr>
<tr>
<td>Purpose</td>
<td>The general formula for the function</td>
</tr>
<tr>
<td>-------------------------------------</td>
<td>--------------------------------------</td>
</tr>
<tr>
<td>Calculates the number of characters in the cell</td>
<td>=LEN(D4)</td>
</tr>
<tr>
<td>Reduce the blanks for the single digits</td>
<td>=TRIM(A4)</td>
</tr>
<tr>
<td>Transition from small to large</td>
<td>=UPPER(F6)</td>
</tr>
<tr>
<td>Transition from large to small</td>
<td>=LOWER(F7)</td>
</tr>
</tbody>
</table>
The most important functions of the logic Function of IF

=IF(logical_test ; value_if_true; value_if_false)

Example:

=IF(A1>=60;"YES";"NO")
Microsoft Excel 2010

Charts and Graphs

![Bar Chart with Data for 2008 and 2009]
Identifying Chart Elements

**Vertical Axis**, also called the \( Y \) axis

**Chart Area**

**Data Label**

**Grid Lines**

**Plot Area**

**Vertical Axis Title**

**Horizontal Axis**
Also called the \( X \) axis

**Chart Title**

**Data Series**

**Legend**

**Data Table**

**Horizontal Axis Title**
Charts make data visual. Instead of having to analyze columns of numbers, you can see at a plethora of information at glance.

To create a chart:

1. Select the table in which you have your data for the chart
2. Click the Insert Tab
3. Click the down arrow of the chart category you want to create (column, line, pie, bar or etc.)
4. Select the type of chart within the category
5. Select and drag the chart to where you want it situated
6. Fine tune it with options in the Chart Tools menu (Design, Layout, and Format)
Design Tab

The Design tab provides tools that give you quick and easy choices for how your chart is laid out, how the elements are labeled, and some color combinations and 3-D effects that can add impact to the overall presentation. Use this tab when you are not concerned about details.

Change Chart Type
This command will change the type of chart that you have currently selected in your spreadsheet, to a different type that you select from a drop-down menu. The old chart disappears and the newly selected chart replaces it.

Save As Template
Saves a chart with the .crtx extension so it can be used as a basis for future charts.

Switch columns and rows
If Excel has misinterpreted your data and mixed up your X and Y axis, you can rectify the problem by pressing this button. This will automatically switch the Y axis data to the X axis and the X axis data to the Y axis.

Select Data
This command will start the Select Data Source dialog box which will allow you to edit the range of data included in the chart.

Chart Layout Gallery
Depending on the chart type you have chosen, the Chart Layout Gallery offers 4-12 built-in combination of chart elements. When you choose a new chart layout from the gallery, you get a predefined combination of titles, legend, gridlines, data labels, and etc. These layouts may not always be what you need, but they will give you the basic elements, which you can then modify.
Chart Styles

The Design tab is also home to the Chart Styles gallery that offers 48 variations of color and effects. The gallery has columns for each of the six accent colors, monochromes and mixed colors.

Moving Charts

If you want to move your chart to another worksheet, the dialog box associated with this function will make it possible. You can choose to have it transferred to a new sheet or to one of the existing sheets using the drop down menu provided in the dialog box.

Layout Tab

The Layout tab contains a few popular choices for formatting 15 chart elements. In 60% of cases, you can use options from the drop-down menus on the Layout tab to create a perfect chart.

Current Selection Command Group

Select Chart Elements

This feature provides a drop-down menu that lists all the elements in the selected chart, such that when you select one from the list, the corresponding element in the chart will be selected

Format Selection

Once the chart element has been selected, you can press this button, which will bring up the format dialog box which can be used to format the element at a very high degree of detail.
Reset to Match Style

If you don’t like the changes you’ve made to the chart element, you can press this button to get back to where you started.

Insert Command Group

Picture
Opens files for selection and insertion of an image into whatever cell is selected

Shapes
Allows for the selection and drawing of a wide range of shapes

Text Box
Provides for the drawing of a text box anywhere in the chart

Labels Command Group

Chart Title

- By default, a chart with more than one series is created without any title.
- When the title is added above the chart, Excel shrinks the plot area to make more room for the title.
- The title is selected by default so you can immediately type the actual title, which will appear in the formula bar.
- Press the Enter key to finalize your chart title.
- You can also select the text in the box and type your title over it.
- To edit the title text, select the text and use the text editing tools in the Font and Paragraph sections of the Home tab.
- To edit the title box you can either use the Chart Tools Format ribbon on the tool bar, or right click the Title box and select “Format Chart Title” which provides an extensive range of options.
- To help the reader interpret the chart, include the message in the title. Instead of using an Excel generated title such as “Sales,” you can actually use a two- or three-lined title such as “Sales have grown every quarter except for Q3, when a strike impacted production.”
**Axis Titles**

The Axis Title button on the Layout tab displays four options when clicked: No Title, Rotated Title, Horizontal Title, and Vertical Title.

- The Rotated Title faces the plot area of the chart,
- the Horizontal title is parallel to the horizontal axis,
- the Vertical title reads from top to bottom.

For the Horizontal Axis title the only option is to turn it on or off.

All the formatting options available for the chart title also apply to the axis titles.

**Legend**

- The built in choices for the legend include having the legend outside the left, right, bottom, or top of the plot area.

- If you move the legend to the top or the bottom, Excel rearranges the legend in a horizontal format.

- **Floating a Legend in the Plot Area**

  To float the legend in the Plot Area:

  ◈ From the Layout tab, select the Legend drop-down ➝ Overlay Legend at Right. This keeps the legend in a vertical arrangement and stretches the plot area out to the edge of the chart.

  ◈ Carefully click inside the legend. When the mouse pointer is a four-headed arrow, drag the mouse and drop the legend in a free spot on the chart.

  ◈ While the legend is still selected, click the Format tab. Select Shape Fill, White, to convert the transparent fill to a solid fill. The fill prevents gridlines from overwriting your legend titles.

  ◈ Select Format ➝ Shape Outline ➝ Black to add a border around the legend.
Changing the Arrangement of a Legend

To change the arrangement of a legend:

- Click the legend to activate the resizing handles → Drag the bottom-right corner of the legend up and out to produce a legend with the labels arranged in a horizontal format.

Data Labels

- Data labels can make things clearer and help you communicate the significance of what is being presented.

Adding Data Labels to a chart

You can insert data labels by

- selecting the series for which you want the labels,
- selecting the Data Labels button on the Layout tab, or
- selecting one of the following locations from the drop-down list.
  - Outside End, Center, Inside End, Inside Base, and None.
- The three “inside” choices are useful when you have a stacked column chart.

Nudging a Label

If you want to adjust the position of your data labels to either separate them from each other or get them closer to the series to which they relate, you can do so by

- clicking once on the one you want to move (this selects all the labels in the series)
- then click again (which selects only the one you are selecting), holding down the mouse key, and nudge the label with the mouse to the desired location.

Formatting Labels

- The Formatting Labels dialog box contains a wide range of formatting options that can enhance labels and make them stand out. However, it does not contain font commands.

- To change the font, font color, font size and alignment, you will need to use the font section of the Home tab, or right click and select Data Labels.
Data Table

- A Data Table is a mini worksheet that appears below a chart.
- An advantage of a data table is that you can see the values of each data point without having to insert labels.
- There are two built-in options in the Data Table drop-down on the Layout tab: You can show the data table with or without legend keys.
- Choosing to show the legend keys can save space because it obviates the need for a legend.
- If you select the More Data Table options in the Data Table drop-down, you will see the usual options for fill, border styles, shadow, and 3-D, plus special data options.

The number of sessions were down this year compared to last year.

<table>
<thead>
<tr>
<th>Month</th>
<th>2010</th>
<th>2011</th>
</tr>
</thead>
<tbody>
<tr>
<td>July</td>
<td>2422</td>
<td>2698</td>
</tr>
<tr>
<td>Aug</td>
<td>2117</td>
<td>4231</td>
</tr>
<tr>
<td>Sept</td>
<td>2807</td>
<td>4687</td>
</tr>
<tr>
<td>Oct</td>
<td>4801</td>
<td>7417</td>
</tr>
<tr>
<td>Nov</td>
<td>6035</td>
<td>5953</td>
</tr>
<tr>
<td>Dec</td>
<td>5418</td>
<td>4618</td>
</tr>
</tbody>
</table>

Last six months
Axes Command Group

- The Horizontal Axis
  - The Horizontal Axis, also called the Category or X-Axis, appears along the bottom of the chart in column, line, area, and stock charts.
  - Your most important choice for this axis is whether it should be time based or text based.
  - In a text based axis, the points along the axis are equally spaced.
  - In a chart that uses a time-based axis, the points are spaced on the relative time distance between points.

- The Vertical Axis
  - Contains the scale for the numbers plotted in the chart.
  - The primary vertical axis appears along the left side of the chart in column, line, area, and stock charts.
  - Choices for this axis include scaling of the axis, the minimum and maximum value for the axis, and the distance between tick marks on the axis.
More choices are available in the Format Axis Dialog.

If your data has numbers of different scales you should specify a logarithmic axis

- Say that you have a series of data with both large and small data values such as Bookstore sales by products. The Bookstore has high flying products that account for 80% of its revenue and then some older product lines that are still hanging around. When you try to plot these items on a chart, Excel must make the axis scale large enough to show the sales for the best-selling products. This causes the detail for the smaller product lines to become lost because the values are a relatively small percentage of the entire scale.

- When this occurs the solution is to convert the axis to a logarithmic axis. In a logarithmic axis, the distance from 1 to 10 is the same as the distance from one to 100, and so on. This allows you to see detail of the product selling a few hundreds units as well as the products selling 100,000 units.

- To convert to a logarithmic scale, select Layout, Axes, Primary Vertical Axis, Show Axis with Log Scale. The result is a chart which shows detailed data for both small and large amounts.

**Overriding Scale Options**

- When you create a chart, Excel automatically decides whether the vertical axis should reach to zero

- To over-ride the Maximum/Minimum settings for the vertical axis, and thus create the illusion of greater variances in series data:
  
  - Double-click on the axis → Go to Axis Options → Override the minimum value on the axis by selecting the Fixed option button for Minimum → Type a value for the minimum
Gridlines

- Gridlines help the reader locate data on the chart.
- Without gridlines, it is difficult to follow the plotted points over the vertical axis to figure out the value of a point.
- Gridlines work in conjunction with the Major Unit and Minor Unit settings in the Format Axis dialog box.
- Built-in options on the Layout tab for both horizontal and vertical lines allow you to turn on major or minor, major and minor, or no gridlines.
- Creating unobtrusive Gridlines by using format Gridlines:
  - Each Format Gridlines dialog box has three categories in the left navigation bar, which can be used to dim the impact of gridlines.
    - Line Color: Use pale, light colors
    - Line Style: Use dotted or dashed lines at .25 points
    - Shadow: Use dim colored, blurred shadow
Background Command Group

Plot Area

- Using a Gradient

To apply a gradient to the plot area, do the following steps:

- Select Plot Area → More Plot Area Options from the Background section of the Layout Tab
- Change the Fill setting from Automatic to Gradient Fill
- Choose Linear Gradient
- Change the angle to 90 degrees
- Each chevron shape on the Gradient Stops bar indicates a gradient stop.
- If there are more than 2 stops, select the last stop and click the minus button to remove that stop.
- Continue to remove any stop higher than Stop 2
- Click the first stop chevron to work with Stop 1
- Choose a green color.
- Set the stop position at 5% by either using the spin button or dragging the chevron
- Set the transparency to 25% to make a lighter green
- Click the Stop 2 chevron
- Choose white as the color
- Set the stop position to 95%

The result is a 2-color gradient from dark green at the top to white at the bottom
Using a Picture or Texture

- When you select the Picture or Texture option, texture is the default setting, and you can select a texture of your choice using the Texture button.
- To use a picture, click the File or Clip Art button and browse to locate a picture to insert.
- Use your Picture as Texture check box to create a repeating image across the background.
- You can adjust the size of the image using the offsets set out below the Stretch Options heading.
- You can lighten the background image, and thus make it less intrusive, by using the Transparency slider at the bottom of the box.